error "No UDK3 Modules found, check installation" when using C api

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • error "No UDK3 Modules found, check installation" when using C api

      Hello everyone, I downloaded the udk3-1.5.1 api and setup from forum and installed it. Then I tried to program with the C API, I link the project with .lib and put the dll in the enviroment path. But when I tried to call the CeInit() function, it replies with No UDK3 Modules found, check installation, I did install the corresponding driver successfully. What's more strange is that if I use CDLL in python ctypes to load the dll, everything is OK. So what happened to C api that it fails to find the udk3 modules, could anyone give me some advice please?
    • Dear Hualiang,

      I suppose you want to use the UDK3 with an EFM-01, EFM-02, or EFM-03 module attached to
      a PC via USB. On Windows, you need both ud3-1.5.1-x86.dll and udk3mod-1.5.1-winusb-x86.dll
      (this file or its 64-bit variant is usually meant by the error message "no UDK3 modules found")
      for 32-bit applications, and both ud3-1.5.1-x86_64.dll and udk3mod-1.5.1-winusb-x86_64.dll
      for 64-bit applications.

      Our free installation support for our EFM boards includes helping you to make our UDK3 binary
      applications run: UDK3 Board Manager and UDK3 Performance Monitor. We don't help you set up
      your specific compiler toolchain or develop customer-specific applications for free. It is quite
      unlikely that other CESYS customers will help you with these issues in this forum, either.

      If you need help setting up your specific compiler toolchain or developing customer-specific
      applications, we can offer support hours packages with costs for it. If you are interested
      in paid support, please contact for details.

      Best regards

      Manfred Radimersky
      Software Development
      Cesys GmbH