EFM-03 Getting Started: Failed to program "efm03_wrapper.bin" with UDK3 Board Manager

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • EFM-03 Getting Started: Failed to program "efm03_wrapper.bin" with UDK3 Board Manager

      Hello there,

      This is Dawei again. From page 10 of hardware reference, it mentions
      "To help the system designer to successfully implement a Artix-7 design some crucial peripherals are installed onboard, with a VHDL reference design 'efm03_wrapper' readily available"

      So I tried it out on UDK3 Board Manager. However, I got the "Failure in control transfer" error, as attached. Any idea where I could be missing?

      In addition, I tried to connect to FPGA JTAG directly through J13 on evaluation board, with Digilent HS2 programming cable. But it was not able to identify the Xilinx FPGA.

      FYI - This EFM-03 is powered on USB bus, with the red jumper J5 on, and I saw a green LED on. I also measured the core FPGA voltage, which is 1.0V. So it means the on board regulators should be working.

      Any suggestion would be appreciated.

      Thanks,
      Dawei
      Dateien
      • board manager.PNG

        (19,96 kB, 7 mal heruntergeladen, zuletzt: )
    • Hello Dawei,

      From the screenshot, I believe you are using Windows-10. I tried the issue with our Windows-10 setup and it seems to work without any errors here.
      It is very difficult from your description to reproduce the issue. Could you please provide more details.

      Meanwhile, some tips:

      As stated in EFM-03-Hardware-Reference (UG120, page 8), "According to the USB specifications, the FPGA power supplies are only switched on, when an USB connection has been established and FX-3 firmware has been downloaded successfully". This could be the reason for JTAG not detecting the FPGA and the error message.

      Please take the following precautions:
      1. Please make sure to use the USB3.0 ports of PC back panel instead of the ones in the front panel.
      (The ports in front panel are often error prone and unreliable, at least for USB3.0)
      2. Please use USB3.0 ports instead of USB2.0 ports. They provide more current than the USB2.0 ports.
      3. Please check the USB cable, try another one to be sure.
      4. When using UDK3 BoardManager, please make sure to "Close Device" whenever EFM-03 is disconnected from PC and "Open Device" after reconnecting.

      Regards,
      Vinay
      FPGA Development
      CESYS GmbH