CEBO-LC: Unstimmigkeiten im Rauschverhalten?

      CEBO-LC: Unstimmigkeiten im Rauschverhalten?

      Hey,

      ich mache seit einiger Zeit Probemessungen mit dem CEBO-LC um die Rausch- und Datenerfassungsqualität für meine Bachelorarbeit zu quantifizieren. Ich messe 5 Kanäle einer Fünflochsonde (Drucksonde) mit 1kSPS differenziell im Spannungsberech von +/-10V.

      Der erste diff. Kanal (diff1, blau) misst recht genau, jedoch sind diff2-diff5 extrem verrauscht. In der Grafik habe ich der Übersichtshalber nur diff1 (blau) & diff2 (orange) dargestellt. Um sicher zu stellen, dass das Rauschen vom CEBO-LC stammt, habe ich zwei Offsetmessungen gemacht, wobei bei der zweiten Offsetmessung, die Kanäle vertauscht wurden. Also diff1 der Drucksonde an diff2 des CEBO-LC und andersherum.

      Außerdem scheint das Rauschen von diff1 (blau) nach oben hin abgedeckelt bzw. abgeschnitten.

      Vielleicht kann mir jemand dieses Rauschverhalten und die Deckelung näher erläutern.

      Vielen Dank! :)
      CCr

      Hallo CCr,

      eine Abtastfrequenz von 1 kHz mit 5 Kanälen bedeutet einen Multiplexer-Wechsel
      mit 5 kHz, also hat das Gerät für eine Messung 200 Mikrosekunden Zeit. Mit
      der Verstärkung 1 für den Messbereich 0 bis 10 V sollten schon 16 Mikrosekunden
      reichen, vorausgesetzt, die Quellimpedanz liegt unter 1 Kilo-Ohm. Wie gross
      ist Ihre Quellimpedanz?

      Mit freundlichen Grüßen,

      Manfred R.
      Software Development
      Cesys GmbH
      Hallo maradim,

      vielen Dank für Ihre Antwort. Die Drucksonde um die es sich handelt ist eine Fünflochsonde von Aeroprobe. Die Spannungsausgabe wird mittels eines Amplifier Moduls (M-INT, ebenfalls von Aeroprobe) auf +/-5V verstärkt. Am Eingang dieses Moduls liegt die Impedanz im Bereich von 1 Kilo-Ohm. Auf weitere Rückfragen beim Hersteller wie hoch die Impedanz am Ausgang ist, habe ich leider noch keine konkrete Antwort bekommen, jedoch wird diese unter der 1K-Marke liegen.

      Mit freundlichem Gruß
      CCr
      Hallo,

      die Hersteller der Drucksonde können leider aktuell keine Impedanzwerte für die angestrebte Abtastrate bereit stellen. Ich stelle mir jedoch immer noch die Frage, wieso der erste Kanal des CEBO-LC so viel rauschfreier ist als die anderen. Wissen Sie zudem etwas zur auftretenden "Deckelung", die ich im ersten Post erwähnt habe?

      LG CCr
      Hallo CCr,

      wir vermuten, dass ihre Interchannel-Delay-Zeiten für ihre Messung nicht ausreichend
      sind. Die CEBO-LC macht bei der Messung keine Gleichverteilung aller Messungen
      über die Zeitstrecke, sondern alle nötigen Messungen schnell hinter einander,
      und wartet dann, bis der nächste Messzyklus anfängt. Dadurch ist die erste
      Messung bevorteilt und hat ein Vielfaches an Einschwingzeit für eine Messung
      als es die anderen Kanäle haben. Das muss durch den Parameter "Interchannel
      Delay" ausgeglichen werden.

      Das können Sie aber nicht mit unseren GUI-Applikationen machen, dafür
      müssten Sie eine Applikation unter Nutzung unserer API programmieren,
      weil in unserern GUI-Applikationen CeboMultiLogger und CeboLab dieser
      Parameter leider nicht einstellbar ist.

      Mit freundlichen Grüßen,

      Manfred R.
      Software Development
      Cesys GmbH
      Hallo Manfred,

      vielen Dank, die Vermutung hört sich sehr vielversprechend an. Wir benutzen bereits die API, da wir einen Raspberry Pi mit der Distribution Raspbian zur Datenerfassung verwenden. Ich vermute, dass der Interchannel Delay in einer Header Datei geändert werden soll. Können Sie mir dazu weitere Informationen zur Implementierung geben?

      LG CCr
      Hallo CCr,

      der Interchannel Delay kann per Funktions- oder Methodenaufruf gesetzt werden,
      und ist in der CEBO Programming Reference UG111 dokumentiert:

      cesys.com/fileadmin/user_uploa…programming-reference.pdf

      Für C++ zum Beispiel ist auf den Seiten 54 und 55 die Methode

      int setParameters(const Range &range, int interChannelDelay)

      dokumentiert, wobei interChannelDelay in Mikrosekunden anzugeben ist.

      Mit freundlichen Grüßen,

      Manfred R.
      Software Development
      Cesys GmbH
      Hallo Manfred,

      vielen Dank für Ihre Hilfe. Es liegt tatsächlich an an der interChannelDelay Zeit, und das Problem ist behoben! Allerdings gibts jetzt eine weitere Unstimmigkeit. In der Doku "ug105" steht, dass der Standardwert bei Gain = 1 16us beträgt. Wenn ich den Delay aber auf 10us setze, ist das Rauschen aber immer noch viel geringer als in meinem ersten Post. Kann es sein, dass der Delay standardmäßig 0 beträgt anstatt 16us?

      Hier die Plots dazu. Gleicher Messaufbau wie in meinem ersten Post. Auch im ersten Post wurden 5 Kanäle aufgezeichnet, ich hatte bloß zur Übersicht die letzten drei weggelassen.

      EDIT:
      Mit der Annahme, dass der Delay standardmäßig 0us beträgt, habe ich folgenden Verlauf des SNR (Bei konstanter Spannung) gezeichnet:

      Wie genau ist es möglich, dass der SNR bei A1 ansteigt, obwohl der Multiplexer das Signal sowieso bereits fast eine ganze Millisekunde auf den AD-Wandler legt? Meine Theorie ist, dass der Cebo-LC auch bei der differenziellen Messung einen Multiplexer-Wechsel vornimmt, weshalb der zweite Teil der differenziellen Messung in meiner ersten Messreihe noch ohne Einschwingzeit auskommen musste. Das würde auch das behobene Problem mit der "Deckelung" erklären. Kannst du das bestätigen?

      Ich hoffe, ich hab's einigermaßen verständlich dargestellt.

      LG CCr

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „CCr“ ()