Ubuntu 12.04: libcebomsr-1.3-x64.so wird nicht gefunden

      Hallo johCebo,

      auf der Seite

      cesys.com/download/cebo-lc-stick/

      sind alle notwendigen Installer, Executables, Archive und Dokumentationen verlinkt.
      Mittels

      cesys.com/fileadmin/download/c…ebo/cebomsr-linux-udev.sh

      wird eine udev-Regel installiert, die dafür sorgt, dass das USB-Gerät CEBO-LC
      unter Linux ansprechbar ist. Danach das Archiv

      cesys.com/fileadmin/user_uploa…-linux-1.6-x86_64.tar.bz2

      z.B. im eigenen Home-Verzeichnis auspacken und via

      export LD_LIBRARY_PATH=~/cebomsrapi-linux-1.6-x86_64/runtime

      das Verzeichnis, in dem die libcebomsr-1.6.so liegt, für die nachfolgend in der Shell gestarteten
      Executables kenntlich machen. Dann sollte

      cd ~/cebomsrapi-linux-1.6-x86_64/python
      python InfoExample.py

      funktionieren. Das habe ich hier mit Ubuntu 16.04 LTS getestet. Wenn es mit Ubuntu
      12.04 LTS Probleme geben sollte, beschreiben Sie die aufgetretenen Probleme bitte näher.

      Mit freundlichen Grüßen,

      Manfred R.
      Software Development
      Cesys GmbH
      Vielen Dank für die Anleitung. Nach deren Anwendung bekomme ich:
      `OSError: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /home/cebo/cebomsrapi-linux-1.6-x86_64/runtime/libcebomsr-1.6.so)


      apt-get sagt aber:
      libc6 ist schon die neueste Version. (2.15-0ubuntu10.15)

      Ist es vielleicht besser eine ältere Version der cebomsrapi zu benutzen?

      MfG
      joh

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „johCebo“ ()

      Hallo johCebo,

      wie an der Fehlermeldung ablesbar, ist die notwendige dynamische Bibliothek libcebomsr-1.6.so
      mit einer glibc Version 2.17 erstellt. Diese glibc-Version ist aber mit Ubuntu 12.04 LTS noch nicht
      verfügbar. Wenn Sie stattdessen Ubuntu 14.04 LTS oder 16.04 LTS einsetzen, wird es funktionieren.
      Eine Neu-Installation einer aktuellen Ubuntu-Version ist normalerweise auch schnell gemacht.

      Leider können wir nicht für jede ältere Linux-Distribution ein separates Binary-Paket erstellen
      und vorhalten. Wenn Sie aber unbedingt Ubuntu 12.04 LTS einsetzen müssen, können Sie einen
      Auftrag für die Portierung auf diese Plattform bei sales@cesys.com einreichen.

      Mit freundlichen Grüßen,

      Manfred R.
      Software Development
      Cesys GmbH